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講習会の概要 2 

 参加者自身のPCにCSSをインストールし、実際に
使ってみる 
 まだ一度もCSSを使ったことない方が主な対象者 

 EPICSはある程度知っている前提 

 EPICS IOCがすでに制御ネットワーク上にある前提 

 アシスタント: 三菱SC 中村 卓也 氏 

 ルール 

 ついていけなくなった場合には、遠慮なく手を挙げてくだ
さい。アシスタントがヘルプします。 

 手を挙げている方が多くなれば、一旦中断します。早く進
んでいる方は、周りの方のサポートをお願いします。 

 途中、質問や疑問点があれば遠慮なく声を発してくださ
い。 

 参加者名簿に書いたときの番号は覚えておいてください。 

 



時間割 3 

 10:00 – 10:30 「CSSとは」  ※トークのみ 

 10:30 – 12:00 「CSSを起動してみる」 

 12:30 – 13:30  昼休憩 

 13:30 – 14:30 「CSS BOYを使ってみる」 

 14:30 – 15:00 「CSSの画面構成」 

 15:00 – 15:10 小休止 

 15:10 – 16:00 「BOYの様々なウィジェット」 

 16:00 – 16:30 質疑応答 



謝辞 4 

 この講習会では、ORNL/SNSのDr. Kay Kasemir

の資料を一部使わせていただいております。 
http://www-linac.kek.jp/cont/epics/css/CSS_Talk.ppt 

http://www-linac.kek.jp/cont/epics/css/KEK_CSS_Intro.pptx 

 いくつかの画像については、CSSのオンライン
ヘルプのものを使用しています。 

http://www-linac.kek.jp/cont/epics/css/CSS_Talk.ppt
http://www-linac.kek.jp/cont/epics/css/CSS_Talk.ppt
http://www-linac.kek.jp/cont/epics/css/CSS_Talk.ppt
http://www-linac.kek.jp/cont/epics/css/KEK_CSS_Intro.pptx
http://www-linac.kek.jp/cont/epics/css/KEK_CSS_Intro.pptx
http://www-linac.kek.jp/cont/epics/css/KEK_CSS_Intro.pptx


CSSとは 

初心者向けCSS 講習会@KEK 



トークの前に 6 

 話を聞きながら 

 CSSをダウンロードしてください 

http://www-linac.kek.jp/cont/css/ 

 zipファイルを展開するところまで 

 

 

 

 

 

 

 

 

 

http://www-linac.kek.jp/cont/css/
http://www-linac.kek.jp/cont/css/
http://www-linac.kek.jp/cont/css/


CSSとは 7 

 エンドユーザーにとって 

 オペレータ・実験者・制御システムインテグレー
ター向けの統合されたユーザーインターフェース 

 EPICSの各種ツール（Probe、Strip Chart、etc.）を
置き換える 

 



8 Managed by UT-Battelle 
for the Department of Energy 

CSS: A Collaboration 

 Began in 2006 between 
DESY and SNS 

 Joined by CLS, APS, BNL, 
        , Diamond, …, KEK/J-PARC? 

                   : https://sourceforge.net/apps/trac/cs-studio/wiki 

– Wiki, Mailing lists, code repository 

 Growing presence at EPICS meetings 

 Benefits from Eclipse community 

– EclipseCon 2011: Way over 500 participants from 
~30 countries 

https://sourceforge.net/apps/trac/cs-studio/wiki
https://sourceforge.net/apps/trac/cs-studio/wiki
https://sourceforge.net/apps/trac/cs-studio/wiki


9 Managed by UT-Battelle 
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         CSS: A Control System Architecture 

    

– Portable programming environment with very 
good development tools 

– Basic bundling: Java Archive Files (JARs) 

                  Rich Client Platform (RCP) 

– Extensible bundling: Plug-Ins, Extension points, 
Registry 

– Framework for GUI with menus, windows, sub-
panels, online help, preferences, … 



10 Managed by UT-Battelle 
for the Department of Energy 

CSS: A Software Toolkit 

 It’s BIG 

– Repository: ~ 1.500.000 lines of Java Code 

 

 Structured 

– 70 ‘core’ plugins, about 300 total 

– About 40% of code is comments and formatting 

 

 You pick what you need 

– SNS uses ~300.000 (20%) 
 

Perl cloc tool on July 2011 cs-studio3.0 repo and SNS source snapshot, excluding zip files 



11 Managed by UT-Battelle 
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CSS: A Software Toolkit 

 Library Plug-Ins 

– Life data access, Historic Data Access, Control system data types 
(PV, Sample, …), Logbook    , EMail, Authentication, Authorization, 
… 

– Pluggable 

 Historic Data: XML-RPC, RDB, … 

 Authentication: Kerberos, LDAP, … 

 Application Plug-Ins 

– Strip-Chart: Data Browser 

– OPI: SDS, BOY 

– Alarms: NAMS, BEAST 

– Archive: DESY Archive, BEAUTY 

– Utilities: Probe, Clock     , PV Tree    , Psychiatrist  

 
List of plugins: http://cs-studio.sourceforge.net/plugins.html 

http://cs-studio.sourceforge.net/plugins.html
http://cs-studio.sourceforge.net/plugins.html
http://cs-studio.sourceforge.net/plugins.html


KEK版CSS 12 

 CSSは研究機関ごとに構成が異なります 

 

 

OPI BOY SDS BOY BOY 

アラーム BEAST NAMS BEAST  - 

時系列データ
表示 

Data Browser ? ? Data Browser 

その他 

PV Util 

Rack Util 

PV Fields Viewer 

NameSpace

Browser 
ChannelFinder - 



13 Managed by UT-Battelle 
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BOY – Best OPI, Yet 

         Operator Interface Editor                                           Runtime 

 

 

 

 

 

 

 

 

Similar to EDM, MEDM, SDS, DM2K, but possibly better 

 

 



Data Browser 14 

 PVの現在の値をモニタ 

 アーカイブデータの表示 

 Channl Archiver、RDB Channel Archiver、kblog 

 

 

 



その他 15 

Probe EPICS PV Tree 

PV Table 
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Send PV name to other CSS tools 

 Use common CSS Process Variable context menu to 
send PV name to other CSS tools 



17 Managed by UT-Battelle 
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Flexible Layout 

 Panels can be closed, 
reopened, repositioned 

 Multiple Perspectives 

– Name, Save, Restore 

 Multiple document 
instances share same 
configuration panels  

 

 



逆に混乱する場合も… 18 

 画面構成が自由に変えられる反面… 

 初心者にありがちな声 

 「元々の画面がどっかいってしまった！」 

 「なんか画面がぐちゃぐちゃになって訳分からん。」 

 仕組みを理解すればなんてことはありません 

 午後にこれに関する練習・トラブルシューティング
をしてみます 

 

 



CSSを起動してみる 

初心者向けCSS 講習会@KEK 



参考文献 20 

 KEKのWebサイト上に関連ドキュメント・スラ
イド一覧 

http://www-linac.kek.jp/cont/epics/css/ 

 インストール手順書 
http://www-linac.kek.jp/cont/epics/css/install_css_kek_public.pdf 

 

 

 

http://www-linac.kek.jp/cont/epics/css/
http://www-linac.kek.jp/cont/epics/css/
http://www-linac.kek.jp/cont/epics/css/
http://www-linac.kek.jp/cont/epics/css/
http://www-linac.kek.jp/cont/epics/css/install_css_kek_public.pdf
http://www-linac.kek.jp/cont/epics/css/install_css_kek_public.pdf
http://www-linac.kek.jp/cont/epics/css/install_css_kek_public.pdf
http://www-linac.kek.jp/cont/epics/css/install_css_kek_public.pdf


演習 1-1: Javaのインストール 21 

 JRE バージョン 6が必要 

 Javaのバージョンの確認方法 

 Windows 7 の場合 

 コントロールパネル → Java → Java → 表示 

 

 Linuxの場合 

 $ java –version 

 gcjのものはだめです 

 Mac OS Xの場合 

 Finder で 

 アプリケーション →  

ユーティリティー  →  

Java Preferences 

 



演習 1-1: Javaのインストール 22 

 Javaのインストール方法 
 Windowsの場合 

 http://java.com/ja/  
よりダウンロードしてインストール 

 32bitか64bitか 

 Linuxの場合 
 http://java.com/ja/  
よりダウンロードしてインストール 

 もしくは、各ディストリビューションが用意したJREをイン
ストール 

 32bitか64bitか 

 Mac OS Xの場合 
 http://support.apple.com/kb/TS3489?viewlocale=ja_JP  
を参考にソフトウェアアップデートから Java SE 6 をインス
トール 

 



CSSの起動スクリプト 23 

 各加速器向けに起動スクリプトが用意されてい
ます 

 EPICS_ADDR_LISTの設定 

 Data Browser のためのアーカイバの設定 

 ※現在のところLinac、(Super)KEKB向け以外にはダ
ミーの値が設定されます 

 今日はどれでも 

 css.exeでもよいです 

 

 

 



演習 1-2: CSSの起動 24 

 初回起動時のWelcome画面 

 右上の Workbench をクリック 

 



演習 1-3: Probeでモニタ 25 

 CSS → Diagnostics Tools → Probe を選択 

 PV Name欄にPV名を入力 

 

 

大きさを自分で調整 



ProbeでPVの値がとれない場合 26 

 PVの名前は間違っていませんか？ 

 

 

 addr_listの設定はOKですか？ 

 CSSのメニューより、Edit → Preferences → CSS 

Core → EPICSより 

 何に設定するのかは、 

制御ネットワークの 

管理者に聞くこと 



演習 1-4: Probeで書き換え 27 

 PV Name欄にPV名を入力 

 各自の番号に基づいたPV名を入力してください 

 Adjustにチェックを入れる 

 New Value欄に値を入れて Enter キーを押下 

 

 



演習 1-5: ヘルプ 28 

 CSSの使い方に関しては、Web上のドキュメン
トは非常に少ない 

 http:///cs-studio.sourceforge.net/docbook/ 

 CSS → Help → Help Content 

 

 

http://cs-studio.sourceforge.net/docbook/
http://cs-studio.sourceforge.net/docbook/
http://cs-studio.sourceforge.net/docbook/


演習 1-6: バージョンの確認 29 

 KEK版CSSか？ 

 Welcome画面 で確認（ Help → Welcome） 

 バージョンの確認 

 Help → About → Installation Details ( → Installed 

Software)で確認 

 

 



CSS BOYを使ってみる 

初心者向けCSS 講習会@KEK 



BOYでできること 31 

 CSS自体も高機能だが、その1機能であるBOY

もかなり高機能 

 基本的なOPI編集機能 

 Macro 

 Action 

 Rule 

 Script 

 etc. 

 まず、どんなことができるのかを概観してみま
しょう。 

 



32 Managed by UT-Battelle 
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Simple Things are Easy 

1. Drag a widget, e.g. Knob, from palette to editor 

2. Enter the PV name in Properties view 

3. Click the “Run”      button to execute! 

 

What you will get 

 PV value as text and via knob position 

 PV severity reflected in border color 

 PV name and value shown in tool-tip 

 PV‟s display limits set the knob‟s default range 

 Indicate „disconnected‟ state via a pink border 

 Widget will be greyed-out if read-only 

 

 



33 Managed by UT-Battelle 
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Editing Features 

Add Widgets 

– Drag & Drop from Palette 

– Copy/paste, Ctrl+Drag existing widgets to duplicate 

 

– Snap to grid, guideline, other widgets 

– Align, distribute 

 

Select multiple widgets to 

– Edit common properties 

– Adjust size or move around 
 



34 Managed by UT-Battelle 
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Screen Navigation 

 Idea: Minimize number of open screens. 

 Similar to Web Browser links: 

– Default: Related displays replace the current display. 

– Optional open in „tabs‟ or new window 

– Allow previous/next navigation over display history 
Displays in „Tabs‟ 



35 Managed by UT-Battelle 
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Rules, Scripts 

Rules create dynamic displays 

– Easy: PV → Widget Property 

 

Scripts can to “anything” 

– Read PVs, 
change widget properties, 
open dialog, … 

– JavaScript or Python (Jython) 
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SNS Examples 



37 Managed by UT-Battelle 
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SNS Examples 

 Top-level displays created 
by operators 

Tim Southern, Nick Luciano 



38 Managed by UT-Battelle 
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SNS “Steering” Tool 

 Try to get spot 
into the green, 
at least into 
orange 

Tim Southern, Nick Luciano 



基本的な編集機能 

 

Macro 

Action 

 

Rule 

 

 

Script 

 

 

BOYの便利な機能 39 

難易度 

Hard 

Easy 

できること 

A lot 

Few 



まずは使ってみる 40 

 サンプルで遊んでみる 

 OPIの実行の仕方 

 基本的な使い方 

 プロジェクトの作成 

 OPIファイルの新規作成 

 OPI Editorを使って画面編集 

 ウィジェットの配置 

 プロパティの変更 

 PVの設定 

 OPI Runtimeで実行 

 

 



演習2-1: OPI Editorパースペクティブ 41 

 CSSのメニューより 

Windows → Open Perspective → Other → 

OPI Editor 

を選択 

 ビューの確認 

 



演習2-2: サンプルのインストール 42 

 CSSのメニューより 

CSS → Display → Install OPI Examples 

を選択 

 



演習2-3: OPIの実行 43 

 今のウィンドウの別タブで開く 

 NavigatorビューでOPIファイルを右クリック 

 Open With → OPI Runtimeを選択 

 最初はダブルクリックでもOK 

 



演習2-4: 別ウィンドウで開く 44 

 別のウィンドウで開く 

 NavigatorビューでOPIファイルを右クリック 

 Open With → OPI Editorを選択 

 右上の  をクリック 

 フルスクリーンモードの切り替え F11 

 コンパクトモードの切り替え F8 



演習2-5: プロジェクトの作成 45 

 プロジェクト 

 ただのディレクトリと思ってください 

 演習用のプロジェクトを作成 

 CSSのメニューよりFile→ New → General → 

Projectを選択 

 Use default locationのところに実際には作られます 

 



演習2-6: OPIファイルの作成 46 

 OPIファイルを新規作成 

 Navigatorビューにて、プロジェクトを右クリック 

 New → OPI Fileを選択 

 OPI Editorで作成したOPIファイルが開かれる 



演習2-7: Rectangleの配置 47 

 Rectangleを画面内に配置 

 PaletteよりRectangleをドラッグ＆ドロップ 

 大きさや位置を変えてみてください 

 Rectangleの色を変更 

 PropertiesビューにてBackground Colorの右側をク
リック 

 Choose Colorダイアログで色を選択 

 



演習2-8: 複数ウィジェットの配置 48 

 Rectangleを2つ追加 

 動かしてみると、他のRectangleの左端、右端、上
端、下端、中央に合わせて青い線が出るのを確認 

 複数ウィジェットの配置をそろえる 

 Ctrl + クリックまたはD&Dで囲って複数選択 

 このボタン類を試してみてください 

 

 Primary Selection 

 Ctrl + クリックで最後に 

選んだもの 

 そのウィジェットが基準 



演習2-9: Text Updateの使用 49 

 Text Update 

 EPICSのPVの値を表示するためのウィジェット 

 表示させたいPVをプロパティの PV Nameに設定 

 このOPIを実行 



CSSの画面構成 

初心者向けCSS 講習会@KEK 



用語 51 

 出てくる用語 

 パースペクティブ 

 ビュー 

 エディタ 

 Eclipseと同じ用語 

 Eclipseに関連してインターネット上に用語解説して
いるページがたくさんあります 

 Eclipseを使ったことのある人に聞くのも 

 

 



いざというときのために 52 

 CSSは画面構成が自由に変えられる反面… 

 初心者にありがちな声 

 「元々の画面がどっかいってしまった！」 

 「なんか画面がぐちゃぐちゃになって訳分からん。」 

 仕組みを理解すればなんてことはありません 

 パースペクティブ、ビュー、エディタといった概念
を理解しましょう。 

 具体的にどう元の状態に戻せるのか確認しましょ
う。 

 



画面構成 53 

エディタ ビュー 

ビュー ビュー 

ビュー 



演習 3-1: ビューの移動 54 

 ビューの移動 

 タブをウィンドウ内でD&Dしてみてください 

 同じ領域にあるビューはタブで切り替え 

 



演習 3-2: ビューの再表示 55 

 Navigatorビューを消す 

 ビューを開く 

 Windows → Show View → Navigatorを選択 

 最後に元に戻してください 

 

 



演習 3-3: 高速ビュー 56 

 高速ビュー 

 一時的に表示させたいビュー 

 高速ビューへの仕方 

 ビューのタブを右クリック → Fast View 

 ウィンドウ左下を右クリック → (ビュー名) 

 高速ビューの表示 

 ウィンドウ左下のNavigatorビューのアイコン 

 元に戻すには 

 Navigatorビューのアイコンを右クリック → Fast View 

 表示されているビューのタブを右クリック → Fast View 



演習 3-4: ビューの切り離し 57 

 ビューのみを独立したウィンドウに 

 ビューの移動時にウィンドウ外に持っていく 

 ビューのタブを右クリック → Detached 

 元に戻すには 

 ビューのタブを右クリック → Detached 



演習 3-5: エディタ領域の分割 58 

 エディタ 

 エディタはエディタ領域にしか表示できません 

 エディタ領域内での分割が可能です 

 エディタの分割 

 右下のようにして 

みてください 

 その後、元に戻して 

ください 

 



パースペクティブ 59 

 パースペクティブ 

 ある特定の作業用に用意されたビュー、エディタの
構成・配置のこと 

 パースペクティブの例 

 CSS 

 OPI Editor 

 OPI Runtime 

 Data Browser 

 etc. 



演習 3-6: パースペクティブの切替 60 

 パースペクティブの切替 

 Windows → Open Perspective → Other → OPI 

Runtime 

 Windows → Open Perspective → Other → Data 

Browser 

 一度使ったことのあるパースペクティブ 



演習 3-7: パースペクティブの保存 61 

 パースペクティブの状態の保存 

 何もしなくても保存されます 

 ビューを適当な大きさに変えた後、別のパースペク
ティブに移り、また元のパースペクティブに戻る 

 ビューを適当な大きさに変えた後、CSSを再起動 

(File → Restart CSS) 



BOYの様々なウィジェット 

初心者向けCSS 講習会@KEK 



BOYで何ができるか 63 

 ここまでに使ったウィジェット 
 Text Update 

 これから使ってみるウィジェット 
 Text Update 

 Scaled Widgets 
 Thermometer 

 Scaled Slider 

 Boolean Widgets 
 LED 

 Boolean Switch 

 Action Button 

 XY Graph 

 Data Browser 

 
 



PV関連のウィジェット 64 

 PVの値を監視・制御するのに用いる 

 代表例 
 Text Update 

 PV関連のウィジェットに共通するプロパティ 
 PV Name 

 Border Alarm Sensitive 

 ForeColor Alarm Sensitive 

 BackColor Alarm Sensitive 

 PV関連のウィジェットに共通する機能 
 右クリックすると 

 Show PV Info 

 Process Variableメニュー 



実習 4-1: アラーム 65 

 実習 4-n のために exercise4.opi というファイル
を新規作成 

 アラームに対してどう反応するのかを確認 

 PV NameプロパティにPV名を入力 

 Alarm Sensitiveが yes になっていることを確認 

 BackColor Alarm Sensitiveを yes 

 ForeColor Alarm Sensitive を yes 

 ウィジェットを右クリックして 

 Show PV Info 

 Process Variable → Probe 



Scaled Widgets 66 

 主に数値の監視・制御に用いる 
  監視 

 

 

 

 

 

 

 

 制御 

 
 

Thermometer Tank 

Meter Gauge 

Progress Bar 

Scaled Slider Knob 



Scaled Widgetsに共通のプロパティ 67 

 Minimum, Maximum 

 HIHI, HI, LO, LOLO 
 Show, Level, Color 

 Limits from PV 

 Ticks関連 

 Scale Format 
Value Label Format 
 例) 

 

 

 

 書式の詳細: 
http://download.oracle.com/javase/1.5.0/docs/api/java/text/
DecimalFormat.html 

 

 

実際の値 書式 表示 

1234 #.00 1234.00 

12.3456 #.## 12.35 

1234 0.###E0 1.234E3 

http://download.oracle.com/javase/1.5.0/docs/api/java/text/DecimalFormat.html
http://download.oracle.com/javase/1.5.0/docs/api/java/text/DecimalFormat.html


演習 4-2: Thermometer 68 

 Thermometerを配置 

 PV NameにPV名を入力: $(user): cathodeTempM 

 Limits from PVが yes になっていることを確認 

 UnitをFahrenheitに設定 

 自分で各種 Limits を設定 

 Limits from PVを no に 

 下記を好みに設定 

 Maximum, Minimum 

 Level HIHI, Level HI, Level Lo, Level LOLO 

 Show HIHI, Show HI, Show Lo, Show LOLO 

 全部非表示にしたいときには Show Markers を no に 

 Scale Formatを設定 

 

 



演習 4-3: Scaled Slider 69 

 Scaled Sliderを配置 

 PV NameにPV名を入力 

 実際に値を変更できることを確認 

 同じPVを Thermometer で監視 

 

 

 



Boolean Widgets 70 

 真偽値の監視・制御に用いる 

  監視 

 

 

 

 制御 

 

 

LED 

Boolean Button 

Boolean Switch 

Image Boolean Button 



演習 4-4: LED 71 

 LEDを配置 

 PV NameにPV名を入力 :  $(user):gunOnC 

 Data Typeは Bit のまま 

 PVが列挙型である場合には Enum にするとよい 

 Bitは -1 のまま 

 特定の bit のみを監視するのであれば、0以上の値を設定 

 -1である場合には、零か非零で判定される 

 On Color と Off Color をそれぞれ設定 

 Labelを表示 

 Show Boolean Label を on に 

 On Label と Off Label をそれぞれ設定 

 

 

 



演習 4-5: Boolean Switch 72 

 Boolean Switchを配置 
 PV NameにPV名を入力 

 Data Typeは Bit のまま 
 PVが列挙型である場合には Enum にするとよい 

 Bitは -1 のまま 
 0以上である場合には、その bit が制御対象 

 -1である場合には、0か1か 

 確認ダイアログ 
 誤って値を変えてしまうことを防ぐため 

 Show Confirm Dialog を yes に 

 Confirm Message を任意の文字列に 

 

 
 



Action Button 73 

 ボタンをクリックすることによって… 

 OPIファイルを開く 

 OPIファイルをビューで開く 

 PVに書き込む 

 コマンドを実行する 

 JavaScriptを実行する 

 Pythonを実行する 

 WAVファイルを再生する 

 ファイルを開く 

 Webページを開く 

 



演習 4-7: コマンドを実行 74 

 ボタンを押すことでコマンドを実行 

 Actionボタンを配置 

 Actionプロパティ 

 Execute Commandを追加 

 Commandにコマンドを入力 

 Windowsなら notepad 

 Mac OS Xなら open –a Safari 

 Linuxなら gedit 

 Textプロパティを設定 

 

 
 

 

 



演習 4-8: 別のOPIファイルを開く 75 

 別のOPIファイルをActionボタンから開く 

 Actionボタンを新たに配置 

 Actionプロパティ 

 Open OPIを追加 

 File Pathに別のOPIファイルを指定 

 Targetは以下のうちいずれか 

 Replace 

 Open in new tab 

 Open in new window 

 

 

 



演習 4-9: XY Graph 76 

 ビームの強度をプロット 

 Concatenate Dataを no に 

 X PVに $(user):PM:distancesWF 

 Y PVに $(user):PM:iTrajectoryWF 

 XY Graphは高機能なので自分でいろいろ使って
みてください 



演習 ex: Data Browser 77 

 時間があれば 



最後に 

初心者向けCSS 講習会@KEK 



今日のまとめ 79 

 演習したこと 

 CSSのインストールと起動 

 BOYの基本的な使い方 

 CSSの画面構成 （パースペクティブ等） 

 BOYの様々なウィジェット 

 

 



よりCSSを使いこなすには 80 

 Data Browser 

 BOY 

 Macro、Rule、Script 

 color.def、font.defの設定 

 OPI Schemeの設定 

 etc. 

 ヘルプの活用 

 Help → Help Contents 

 自分でとにかく使ってみる 

 



質疑応答 

初心者向けCSS 講習会@KEK 


